2013-05-14 [長年日記]

_ [忘れる][ruby] mod_rubyは1.8.7でできている

いやあよく忘れる。

#!/usr/local/bin/ruby
require "dbi"
で始まるfuga.rbが動かない。 *.rhtmlからload "fuga.rb"すると動く。shellで動かすと動く。
悩む。目から血が出る。こんな感じになる。
#!/usr/bin/rubyにすると動いた。こいつは1.8.7だ。
#!/usr/local/bin/rubyにすると死ぬ。こいつは1.9.2だ。

たぶん2年くらい解けなかった。アホだ。

_ [ruby][YAML][json] 空白じゃ!天狗の仕業じゃ!

YAML.load()でJSON文字列をパース。
{"fuga": "aho"}
は読めるが
{"fuga":"aho"}
は読めない.YAML.load()がエラーになる。 :の後のスペースが必要というYAMLの仕様だ。

検索キーワード:

記事

  • 2019-10-21
    • 1. [ubuntu]dell製PCでUbuntu18.04がサスペンドから復帰しない件
  • 2019-10-07
    • 1. 突然ログインできなくなった。
    • 2. [Emacs]space <-> tab
  • 2019-09-21
    • 1. [自転車]保険
  • 2019-09-09
    • 1. [Internet]Signin with Googleの制限
    • 2. [自転車]ブレーキパッド交換
  • 2019-08-31
    • 1. [ubuntu]ubuntu18.04のノートPCがサスペンドから復帰しない

カテゴリ

Amazon | Android | apache | Arduino | bash | bluetooth | Books | CakePHP | CakePHP3 | Chrome | CSS | Docker | Eclipse | Emacs | etc | Firefox | Flask | Gadget | git | Gnome | Google | Heroku | HTML | Internet | iPhone | IS01 | IS03 | Java | JavaScript | json | Kotlin | LINE | magento | mysql | nginx | nodejs | Oops | PC | Perl | php | Python | Qt | Ruby | ruby | Shell | tdiary | twitter | ubuntu | unix | Web | Windows | windows | WindowsMobile | WX5 | YAML | zsh | ここか | そば | つくる | つり | できごと | アクアリウム | ギター | セキュリティ | プリンタ | ベース | ボクシング | ポエム | マネー | メシ | ラズパイ | 仕事 | 作家 | 壮絶 | 妄想 | 忘れる | 料理 | | 暑い | 痛い | 社会 | 自転車 | | 車輪 | | 野球 | 銭湯 | 音楽 |

全部 : / 今日 :

近頃

links

profile

もっとヒゲ伸ばしたい。